drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arina Yelchiyeva <arina.yelchiy...@gmail.com>
Subject Re: Contrib Plugin Question
Date Mon, 03 Sep 2018 14:39:55 GMT
Hi Charles.

Recently new udfs module was added under contrib, you can can take look at
that PR for the example.

Regarding unit tests and data availability:
1. create TEST resources folder where you'll copy your data.
2. use dirTestWatcher to copy data to the root / tmp / custom directory.
3. query the data:

public void t() {
  queryBuilder().sql("select * from dfs.`root`.`complex_1.parquet`").printCsv();

Also I would suggest you create module formats under contrib and place your
format plugin module under formats: contrib / formats / format-plugin.

On Mon, Sep 3, 2018 at 4:38 PM Charles Givre <cgivre@gmail.com> wrote:

> Hello all,
> I’m working on a format-plugin for syslog (RFC-5424) data and I’m having
> some strange issues.  I’d like to submit this contribution in the contrib/
> folder, however I cannot seem to get Drill to recognize the module.  I’ve
> built the module separately, and the code works, however, when I try to
> build Drill, it does not recognize the module and I cannot query my data
> (and the unit tests fail).  I’ve added the module to the contrib pom.xml
> file and added the module to the assemble/bin.xml and still no luck.
> Here’s the REALLY weird part.  I can run the unit tests in IntelliJ and it
> works but it does not if I run the tests from the command line.
> The code can be found here:
> https://github.com/cgivre/drill/tree/format-syslog <
> https://github.com/cgivre/drill/tree/format-syslog>
> Does anyone have any suggestions?
> —C

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message