drill-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Givre <cgi...@gmail.com>
Subject Contrib Plugin Question
Date Mon, 03 Sep 2018 13:38:53 GMT
Hello all, 
I’m working on a format-plugin for syslog (RFC-5424) data and I’m having some strange
issues.  I’d like to submit this contribution in the contrib/ folder, however I cannot seem
to get Drill to recognize the module.  I’ve built the module separately, and the code works,
however, when I try to build Drill, it does not recognize the module and I cannot query my
data (and the unit tests fail).  I’ve added the module to the contrib pom.xml file and added
the module to the assemble/bin.xml and still no luck.  Here’s the REALLY weird part.  I
can run the unit tests in IntelliJ and it works but it does not if I run the tests from the
command line. 

The code can be found here: https://github.com/cgivre/drill/tree/format-syslog <https://github.com/cgivre/drill/tree/format-syslog>

Does anyone have any suggestions?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message