drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Khurram Faraaz <kfar...@mapr.com>
Subject Re: Hbase tables in apache drill not showing up
Date Mon, 29 Oct 2018 17:34:04 GMT
Hi,

What is the version of Drill and HBase that you are using ?, Do you see any
errors in drillbit.log file ?

You will have to enable the HBase storage plugin on Drill web UI, and
ensure it is enabled

 {
          "type": "hbase",
          "config": {
            "hbase.zookeeper.quorum": "1.2.3.12",
            "hbase.zookeeper.property.clientPort": "2181"
          },
          "size.calculator.enabled": false,
          "enabled": true
        }


The to query HBase tables you will have to specify the schema in sqlline,
like

sqlline> use hbase;
sqlline> SELECT * FROM <your-hbase-table-name>;

Thanks,
Khurram

On Mon, Oct 29, 2018 at 9:46 AM Schwendimann Thomas I.BSCWI.1701 <
thomas.schwendimann@stud.hslu.ch> wrote:

> Dear Sir or Madam,
>
> I am trying to use apache drill to query an hbase table. I uploaded a
> table "users" through pig. When checking through the hbase shell, I can
> confirm that the table "users" is there and filled with my data. However,
> on apache drill there is no hbase table when using the query "show
> databases". All my hive and mongoDB tables show up however.
>
> These are my configurations:
>
>
> https://urldefense.proofpoint.com/v2/url?u=https-3A__i.imgur.com_147RcUz.png&d=DwIFAg&c=cskdkSMqhcnjZxdQVpwTXg&r=H5JEl9vb-mBIjic10QAbDD2vkUUKAxjO6wZO322RtdI&m=PgdrMUUqChHV8C7nJXcgmZkgP5bOp-e5FzhToQSnWEM&s=7c-Sdd-CwRsDuo5TCE4PyH8LPHquQ5wMhGScGbk8wgw&e=
>
> If you can help me out here it's greatly appreciated.
>
> Thanks in advance.
>
> Thomas
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message