drill-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Rogers <par0...@yahoo.com.INVALID>
Subject Re: [NOTICE] Maven 3.6.3
Date Fri, 17 Apr 2020 17:59:29 GMT
Hi Arina,

Thanks for keeping us up to date!

As it turns out, I use Ubuntu (Linux Mint) for development. Maven is installed as a package
using apt-get. Packages can lag behind a bit. The latest maven available via apt-get is 3.6.0.

It is a nuisance to install a new version outside the package manager. I changed the Maven
version in the root pom.xml to 3.6.0 and the build seemed to work. Any reason we need the
absolute latest version rather than just 3.6.0 or later?

The workaround for now is to manually edit the pom.xml file on each checkout, then revert
the change before commit. Can we maybe adjust the "official" version instead?


Thanks,
- Paul

 

    On Friday, April 17, 2020, 5:09:49 AM PDT, Arina Ielchiieva <arina.yelchiyeva@gmail.com>
wrote:  
 
 Hi all,

Starting from Drill 1.18.0 (and current master from commit 20ad3c9 [1]), Drill build will
require Maven 3.6.3, otherwise build will fail.
Please make sure you have Maven 3.6.3 installed on your environments. 

[1] https://github.com/apache/drill/commit/20ad3c9837e9ada149c246fc7a4ac1fe02de6fe8

Kind regards,
Arina  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message