flink-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vinoyang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (FLINK-12003) Revert the config option about mapreduce.output.basename in HadoopOutputFormatBase
Date Wed, 27 Mar 2019 01:32:00 GMT

    [ https://issues.apache.org/jira/browse/FLINK-12003?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16802334#comment-16802334
] 

vinoyang commented on FLINK-12003:
----------------------------------

[~twalthr] It does not matter. What is your opinion? [~fhueske] If we revoke it, at least
in Flink I didn't see it would cause compatibility issues.

> Revert the config option about mapreduce.output.basename in HadoopOutputFormatBase
> ----------------------------------------------------------------------------------
>
>                 Key: FLINK-12003
>                 URL: https://issues.apache.org/jira/browse/FLINK-12003
>             Project: Flink
>          Issue Type: Improvement
>          Components: Connectors / Hadoop Compatibility
>            Reporter: vinoyang
>            Assignee: vinoyang
>            Priority: Major
>
> In {{HadoopOutputFormatBase}} open method, the config option {{mapreduce.output.basename}}
was changed to "tmp" and there is not any documentation state this change.
> By default, HDFS will use this format "part-x-yyyyy" to name its file, the x and y means
: 
>  * {{x}} is either 'm' or 'r', depending on whether the job was a map only job, or reduce
>  * {{yyyyy}} is the mapper or reducer task number (zero based)
>  
> The keyword "part" has used in many place in user's business logic to match the hdfs's
file name. So I suggest to revert this config option or document it.
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message