giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Dasch <hcs...@gmail.com>
Subject LGPL dependency
Date Fri, 16 Feb 2018 17:37:42 GMT
Hi,

I'm a contributor to Apache Rya (incubating), and during our release
process we came across an incompatible LGPL dependency that appears to
originate from Apache Giraph's dependency on the Findbugs Annotations
library.  Our plan [1] right now is to just make Giraph an optional module
within our project, but I was wondering if you knew any more about that
license compatibility.  Based on some quick searches, it looks like
Findbugs has since become SpotBugs which is still LGPL.

(GNU Lesser Public License) FindBugs-Annotations
(com.google.code.findbugs:annotations:2.0.2 - http://findbugs.sourceforge.ne
t/)

[INFO] org.apache.rya:rya.giraph:jar:3.2.12-incubating
[INFO] +- org.apache.giraph:giraph-core:jar:1.2.0:compile
[INFO] |  +- com.google.code.findbugs:annotations:jar:2.0.2:compile

thanks,
-Jeff

[1] https://github.com/apache/incubator-rya/pull/274

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message