giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dlogothetis <...@git.apache.org>
Subject [GitHub] giraph pull request #89: Fix in HadoopKryo to support higher java versions
Date Thu, 18 Oct 2018 22:04:44 GMT
GitHub user dlogothetis opened a pull request:

    https://github.com/apache/giraph/pull/89

    Fix in HadoopKryo to support higher java versions

    The code inside HadoopKryo parses the java.version property in a way that expects a single
digit minor java version, e.g. 1.9, which won't work for 1.10 and greater.
    
    Tests
     - mvn clean install
     - ran a number of jobs

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/dlogothetis/giraph kryo_java_version

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/giraph/pull/89.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #89
    
----
commit 9dc03eb7803b4c9524250ef3ed3b874494d80863
Author: Dionysios Logothetis <dlogothetis@...>
Date:   2018-10-18T16:31:08Z

    Fix in HadoopKryo to support higher java versions

----


---

Mime
View raw message