gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From lewis john mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: java.lang.RuntimeException compile failure with trunk 1153872
Date Sat, 06 Aug 2011 17:17:19 GMT
Thank you for both suggestions.

The patch worked a treat Enis so thank you for this. It is interesting to
discover that the cache was the problem. Compile output supplied as below.

publish-local:
:: delivering :: org.apache.gora#gora-tutorial;working@lewis-01 ::
0.2-incubating :: integration :: Sat Aug 06 18:12:14 BST 2011
    delivering ivy file to
/home/lewis/ASF/gora/gora-tutorial/build/ivy-0.2-incubating.xml
:: publishing :: org.apache.gora#gora-tutorial
    published gora-tutorial to
/home/lewis/.ivy2/local/org.apache.gora/gora-tutorial/0.2-incubating/jars/gora-tutorial.jar
    published ivy to
/home/lewis/.ivy2/local/org.apache.gora/gora-tutorial/0.2-incubating/ivys/ivy.xml
     [echo] project gora-tutorial published locally with version
0.2-incubating

BUILD SUCCESSFUL
Total time: 5 minutes 0 seconds

The question I have though is that what would have caused data to be written
to the cache if it was a clean checkout from svn? I had only tried to
compile the code from clean check out, no changes were made prior to $ant
from $GORA_HOME.

Thanks again for the help on this one.


On Thu, Aug 4, 2011 at 7:18 PM, Alexis <alexis.detreglode@gmail.com> wrote:

> > Looking closer I can see that the <dependency org="org.apache.cassandra"
> > name="cassandra-thrift" rev="0.8.1"/> exists in
> > $GORA_HOME/gora-cassandra/ivy/ivy.xml, however what I am puzzled at is
> from
> > where else the artefact retrieval is being duplicated?
>
> Sometimes if you ask Ivy not to download the javadoc and sources, you
> get the around the error:
>
> <dependency org="org.apache.cassandra" name="cassandra-thrift"
> rev="0.8.1" conf="*->*,!javadoc,!sources"/>
>



-- 
*Lewis*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message