gora-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Viacheslav Dobromyslov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (GORA-69) Xerces version conflict produces ERROR messages in the logs.
Date Tue, 16 Sep 2014 13:13:33 GMT

    [ https://issues.apache.org/jira/browse/GORA-69?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14135398#comment-14135398
] 

Viacheslav Dobromyslov edited comment on GORA-69 at 9/16/14 1:13 PM:
---------------------------------------------------------------------

There are several modules depending on org.jdom:jdom package:
* gora-dynamodb
* gora-sql
* gora-cassandra
* gora-goraci
* gora-hbase
* gora-mongodb
* gora-tutorial

`org.jdom:jdom` version is set to 1.1.2 in the root gora `pom.xml`. This `jdom` package depends
on `jaxen:jaxen` which depends on the old `xerces:xercesImpl` 2.6.2 version. And this is the
main cause of the exception.
To eliminate the problem we just need to update `org.jdom:jdom` to 1.1.3 version. And there's
no need to track xerces in the dependencyManagement section anymore.




was (Author: dobromyslov):
There are several modules depending on org.jdom:jdom package:
* gora-dynamodb
* gora-sql
* gora-cassandra
* gora-goraci
* gora-hbase
* gora-mongodb
* gora-tutorial

`org.jdom:jdom` version is set to 1.1.2 in the root gora `pom.xml`. This `jdom` package depends
on `jaxen:jaxen` which depends on the old `xerces:xercesImpl` 2.6.2 version. And this is the
main cause of the exception.
To eliminate the problem we just need to update `org.jdom:jdom` to 1.1.3 version. And there's
no need to track xerces in the dependencyManagement section.



> Xerces version conflict produces ERROR messages in the logs.
> ------------------------------------------------------------
>
>                 Key: GORA-69
>                 URL: https://issues.apache.org/jira/browse/GORA-69
>             Project: Apache Gora
>          Issue Type: Sub-task
>            Reporter: Ioannis Canellos
>            Assignee: Ioannis Canellos
>            Priority: Trivial
>             Fix For: 0.2
>
>
> Failed to set setXIncludeAware(true) for parser org.apache.xerces.jaxp.DocumentBuilderFactoryImpl@3801318b:java.lang.UnsupportedOperationException:
This parser does not support specification "null" version "null"
> java.lang.UnsupportedOperationException: This parser does not support specification "null"
version "null"
> Not directly linked to the failures, but should be fixed anyway.
> The issues is the same as NUTCH-964, so we will have to make sure we use the right xerces
version.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message