hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Castain <...@open-mpi.org>
Subject Re: MPI Java bindings now available
Date Wed, 22 Feb 2012 18:25:33 GMT
Hi Noah

Your LD_LIBRARY_PATH has to include the path to the OMPI libraries so we can find libmpi.
Did you include your $prefix/lib[64] in it?

On Feb 22, 2012, at 11:02 AM, Noah Watkins wrote:

> Just gave the nightly release a try and I'm getting an error:
> 
> nwatkins@kyoto:~/projects/openmpi_java/openmpi-1.7a1r25994/examples$ mpirun -np 1 java
Hello
> JAVA BINDINGS FAILED TO LOAD REQUIRED LIBRARIES
> 
> My setup is on the latest Ubuntu with:
> 
> 1. Built with contrib/platform/hadoop/linux
> 2. Compiled example with mpijavac
> 3. LD_LIBRARY_PATH set to /mpi/java/install/lib
> 
> Looks like Java is loading libmpi_java successfully, and something is going awry with
the library magic in mpi_MPI.c:loadGlobalLibraries()
> 
> Thanks,
> Noah
> 
> On Feb 21, 2012, at 3:05 PM, Ralph Castain wrote:
> 
>> Hi folks
>> 
>> With support from EMC, several of us in the Open MPI community (including LANL, Cisco,
HLRS, Oracle, and IBM) have integrated Java bindings into the Open MPI code. The new bindings
are not part of a formal release as this time (will be in the upcoming 1.7 series), but can
be obtained from the Open MPI web site at:
>> 
>> http://www.open-mpi.org/nightly/trunk/
>> 
>> Instructions on how to build the binding support, build and run applications, etc.
can be found in our FAQ section:
>> 
>> http://www.open-mpi.org/faq/?category=java
>> 
>> Please feel free to post questions and bug reports to the OMPI User mailing list:
>> 
>> http://www.open-mpi.org/community/lists/ompi.php
>> 
>> 
>> I hope to release a version of Hamster in the not-too-distant future, once I finally
get the 0.23 Hadoop release branch to successfully build and run on at least one of my machines
(I've given up on the trunk). :-/
>> 
>> Ralph
>> 
> 


Mime
View raw message