hadoop-common-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kai Zheng (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HADOOP-9927) USER_KERBEROS_LOGIN in UGI should use Krb5LoginModule as REQUIRED, instead of OPTIONAL
Date Tue, 03 Sep 2013 09:10:52 GMT
Kai Zheng created HADOOP-9927:
---------------------------------

             Summary: USER_KERBEROS_LOGIN in UGI should use Krb5LoginModule as REQUIRED, instead
of OPTIONAL
                 Key: HADOOP-9927
                 URL: https://issues.apache.org/jira/browse/HADOOP-9927
             Project: Hadoop Common
          Issue Type: Bug
          Components: security
            Reporter: Kai Zheng
            Assignee: Kai Zheng


Krb5LoginModule should be used as a required login module in the JAAS chain for user to login
via ticket cache in secured/Kerberos deployment. It's probably a work around to pass various
unit tests, however it's obviously problematic and should be fixed. It's possible when relevant
UGI changes are ready and MiniKDC can be employed to help with the tests with HADOOP-9893
being done.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message