hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HADOOP-9613) [JDK8] Update jersey version to latest 1.x release
Date Wed, 11 May 2016 12:16:13 GMT

    [ https://issues.apache.org/jira/browse/HADOOP-9613?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15280031#comment-15280031
] 

ASF GitHub Bot commented on HADOOP-9613:
----------------------------------------

Github user aajisaka commented on a diff in the pull request:

    https://github.com/apache/hadoop/pull/76#discussion_r62836827
  
    --- Diff: hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-applicationhistoryservice/src/test/java/org/apache/hadoop/yarn/server/timeline/webapp/TestTimelineWebServices.java
---
    @@ -81,11 +82,9 @@
       private static TimelineStore store;
       private static TimelineACLsManager timelineACLsManager;
       private static AdminACLsManager adminACLsManager;
    -  private long beforeTime;
    +  private static long beforeTime;
     
    -  private Injector injector = Guice.createInjector(new ServletModule() {
    -
    -    @SuppressWarnings("unchecked")
    --- End diff --
    
    It looks to me that the javac warning is related because the patch removes `@SuppressWarnings("unchecked")`.


> [JDK8] Update jersey version to latest 1.x release
> --------------------------------------------------
>
>                 Key: HADOOP-9613
>                 URL: https://issues.apache.org/jira/browse/HADOOP-9613
>             Project: Hadoop Common
>          Issue Type: Sub-task
>          Components: build
>    Affects Versions: 2.4.0, 3.0.0
>            Reporter: Timothy St. Clair
>            Assignee: Tsuyoshi Ozawa
>              Labels: maven
>         Attachments: HADOOP-2.2.0-9613.patch, HADOOP-9613.004.incompatible.patch, HADOOP-9613.005.incompatible.patch,
HADOOP-9613.006.incompatible.patch, HADOOP-9613.007.incompatible.patch, HADOOP-9613.008.incompatible.patch,
HADOOP-9613.009.incompatible.patch, HADOOP-9613.010.incompatible.patch, HADOOP-9613.011.incompatible.patch,
HADOOP-9613.012.incompatible.patch, HADOOP-9613.013.incompatible.patch, HADOOP-9613.014.incompatible.patch,
HADOOP-9613.014.incompatible.patch, HADOOP-9613.015.incompatible.patch, HADOOP-9613.016.incompatible.patch,
HADOOP-9613.1.patch, HADOOP-9613.2.patch, HADOOP-9613.3.patch, HADOOP-9613.patch
>
>
> Update pom.xml dependencies exposed when running a mvn-rpmbuild against system dependencies
on Fedora 18.  
> The existing version is 1.8 which is quite old. 



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message