hadoop-common-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Viraj Jasani (Jira)" <j...@apache.org>
Subject [jira] [Updated] (HADOOP-17650) Fails to build using Maven 3.8.1
Date Fri, 23 Apr 2021 06:21:00 GMT

     [ https://issues.apache.org/jira/browse/HADOOP-17650?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Viraj Jasani updated HADOOP-17650:
----------------------------------
    Release Note: In order to resolve build issues with Maven 3.8.1, we have to bump Solr
to latest version 8.8.2 as of now. By doing so, we would recommend upgrading Solr server accordingly
before upgrading entire Hadoop cluster to 3.4.0.

> Fails to build using Maven 3.8.1
> --------------------------------
>
>                 Key: HADOOP-17650
>                 URL: https://issues.apache.org/jira/browse/HADOOP-17650
>             Project: Hadoop Common
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 3.4.0
>            Reporter: Wei-Chiu Chuang
>            Assignee: Viraj Jasani
>            Priority: Major
>              Labels: pull-request-available
>          Time Spent: 1.5h
>  Remaining Estimate: 0h
>
> The latest Maven (3.8.1) errors out when building Hadoop (tried trunk)
> {noformat}
> [ERROR] Failed to execute goal on project hadoop-yarn-applications-catalog-webapp: Could
not resolve dependencies for project org.apache.hadoop:hadoop-yarn-applications-catalog-webapp:war:3.4.0-SNAPSHOT:
Failed to collect dependencies at org.apache.solr:solr-core:jar:7.7.0 -> org.restlet.jee:org.restlet:jar:2.3.0:
Failed to read artifact descriptor for org.restlet.jee:org.restlet:jar:2.3.0: Could not transfer
artifact org.restlet.jee:org.restlet:pom:2.3.0 from/to maven-default-http-blocker (http://0.0.0.0/):
Blocked mirror for repositories: [maven-restlet (http://maven.restlet.org, default, releases+snapshots),
apache.snapshots (http://repository.apache.org/snapshots, default, disabled)] -> [Help
1]
> {noformat}
> According to [https://maven.apache.org/docs/3.8.1/release-notes.html#how-to-fix-when-i-get-a-http-repository-blocked]
we need to update our Maven repo.
>  
> Maven 3.6.3 is good.
>  
> (For what is worth, I used my company's mirror to bypass this error. Not sure what is
a good fix for Hadoop itself)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: common-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: common-issues-help@hadoop.apache.org


Mime
View raw message