hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ayush Saxena <ayush...@gmail.com>
Subject Re: Yetus unable to build YARN / HADOOP for any patch
Date Mon, 05 Jul 2021 20:52:28 GMT
Got it sorted,made changes in HDFS-PreCommit and triggered the build:

https://ci-hadoop.apache.org/view/Hadoop/job/PreCommit-HDFS-Build/669/console

Got the result:

https://issues.apache.org/jira/browse/HDFS-16101?focusedCommentId=17374991&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-17374991


This worked, but I have also changed the user to Hudson from the original hadoopci as of now.
May be I am missing something or the creds got screwed up. Need to check that.

For the time being we can use Hudson? If so we can do the same changes in all other pre commit
jobs as well and see if things work.  I can check and get the creds stuff sorted out in a
couple of days…

-Ayush

> On 05-Jul-2021, at 6:31 PM, Ayush Saxena <ayushtkn@gmail.com> wrote:
> Yeps, something is broken since last week. I tried a bunch of things on HDFS-PreCommit
this weekend, kept on solving issues one after the other.
> 
> https://issues.apache.org/jira/browse/HADOOP-17787?focusedCommentId=17374212&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-17374212
> 
> First it was the hadoop.sh path was coming wrong, I fixed it, post that it wasn’t able
to download the patch, added jira as plugin, then the curl started failing with 22 error code,
the hadoop ci creds were being rejected. I changed it to Hudson for trying, it downloaded
the patch successfully. Post that it started giving error :
> 
> Unprocessed flag(s): --brief-report-file --html-report-file --mvn-custom-repos  --shelldocs
--mvn-javadoc-goals --mvn-custom-repos-dir
> 
> https://ci-hadoop.apache.org/view/Hadoop/job/PreCommit-HDFS-Build/664/console
> 
> Here I left it. Not sure what broke it and whether INFRA folks would help us on this.
The errors are coming from our scripts. 
> 
> But we need to fix it somehow. Do let me know if anyone has any pointers to any recent
change which might affect us.
> 
> -Ayush
> 
>> On 05-Jul-2021, at 6:06 PM, Szilárd Németh <snemeth@apache.org> wrote:
>> Hi All,
>> 
>> We are experiencing a build issue for HADOOP / YARN, this phenomenon
>> started around last week.
>> Just reported an infra ticket to tackle this:
>> https://issues.apache.org/jira/browse/INFRA-22079
>> Do you think of anything else we can do at this point?
>> 
>> 
>> Best regards,
>> Szilard

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message