hadoop-yarn-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (Jira)" <j...@apache.org>
Subject [jira] [Resolved] (YARN-10847) Build fails on MacOS 10.15
Date Wed, 07 Jul 2021 02:18:00 GMT

     [ https://issues.apache.org/jira/browse/YARN-10847?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Akira Ajisaka resolved YARN-10847.
----------------------------------
    Resolution: Invalid

Please do not change the package name when building Apache Hadoop.

> Build fails on MacOS 10.15
> --------------------------
>
>                 Key: YARN-10847
>                 URL: https://issues.apache.org/jira/browse/YARN-10847
>             Project: Hadoop YARN
>          Issue Type: Bug
>    Affects Versions: 3.2.0
>            Reporter: Abhinav Kumar
>            Priority: Major
>
> [INFO] --- maven-enforcer-plugin:3.0.0-M1:enforce (depcheck) @ hadoop-yarn-server-timelineservice-hbase-common
---
> [WARNING] 
> Dependency convergence error for commons-lang:commons-lang:2.6 paths to dependency are:
> +-org.uscbrft.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-common:3.2.0
>  +-org.apache.hbase:hbase-common:1.2.6
>  +-commons-lang:commons-lang:2.6
> and
> +-org.uscbrft.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-common:3.2.0
>  +-org.apache.hbase:hbase-common:1.2.6
>  +-org.apache.hadoop:hadoop-common:2.5.1
>  +-commons-lang:commons-lang:2.6
> and
> +-org.uscbrft.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-common:3.2.0
>  +-org.apache.hbase:hbase-common:1.2.6
>  +-org.apache.hadoop:hadoop-common:2.5.1
>  +-commons-configuration:commons-configuration:1.6
>  +-commons-lang:commons-lang:2.4
> and
> +-org.uscbrft.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-common:3.2.0
>  +-org.apache.hbase:hbase-common:1.2.6
>  +-org.apache.hadoop:hadoop-mapreduce-client-core:2.5.1
>  +-org.apache.hadoop:hadoop-yarn-common:2.5.1
>  +-org.apache.hadoop:hadoop-yarn-api:2.5.1
>  +-commons-lang:commons-lang:2.6
> and
> +-org.uscbrft.apache.hadoop:hadoop-yarn-server-timelineservice-hbase-common:3.2.0
>  +-org.apache.hbase:hbase-common:1.2.6
>  +-org.apache.hadoop:hadoop-mapreduce-client-core:2.5.1
>  +-org.apache.hadoop:hadoop-yarn-common:2.5.1
>  +-commons-lang:commons-lang:2.6
> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with
message:
> Rule 0: org.apache.maven.plugins.enforcer.DependencyConvergence failed with message:
> Failed while enforcing releasability. See above detailed error message.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-dev-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-dev-help@hadoop.apache.org


Mime
View raw message