hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vihang Karajgaonkar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HIVE-19164) TestMetastoreVersion failures
Date Fri, 13 Apr 2018 22:32:00 GMT

    [ https://issues.apache.org/jira/browse/HIVE-19164?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16438016#comment-16438016
] 

Vihang Karajgaonkar commented on HIVE-19164:
--------------------------------------------

I don't know what changed which started to break the test but it seems to me that the {{setVersion}}
method in this test directly initializes the ObjectStore and then calls setConf. However,
that would not update the version table since that code path gets executed via {{checkSchema}}
method which gets called when its instantiated via {{HiveMetaStore.HMSHandler.getMSForConf(hiveConf)}}.
Once I make that change the test starts working for me.

> TestMetastoreVersion failures
> -----------------------------
>
>                 Key: HIVE-19164
>                 URL: https://issues.apache.org/jira/browse/HIVE-19164
>             Project: Hive
>          Issue Type: Sub-task
>          Components: Test
>            Reporter: Vineet Garg
>            Assignee: Alan Gates
>            Priority: Major
>             Fix For: 3.0.0
>
>         Attachments: HIVE-19164.patch
>
>
> Following tests are failing consistently and are reproducible on master:
> * testVersionMatching
> * testMetastoreVersion
> I tried debugging it and found that ObjectStore.getMSSchemaVersion() throws an exception
{{No matching version found}}. 
> To fetch schema version this method executes {code:sql} SELECT FROM org.apache.hadoop.hive.metastore.model.MVersionTable
{code} but for whatever reason execution returns empty result set resulting in the exception.
Both test failures are due to this exception. I tried debugging the query execution but didn't
really go nowhere with it. I suspect this could be due to recent metastore changes. I tried
reproducing this outside test but with no success.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message