hive-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Work logged] (HIVE-21844) HMS schema Upgrade Script is failing with NPE
Date Mon, 10 Jun 2019 02:42:00 GMT

     [ https://issues.apache.org/jira/browse/HIVE-21844?focusedWorklogId=256578&page=com.atlassian.jira.plugin.system.issuetabpanels:worklog-tabpanel#worklog-256578
]

ASF GitHub Bot logged work on HIVE-21844:
-----------------------------------------

                Author: ASF GitHub Bot
            Created on: 10/Jun/19 02:41
            Start Date: 10/Jun/19 02:41
    Worklog Time Spent: 10m 
      Work Description: maheshk114 commented on pull request #667: HIVE-21844 : HMS schema
Upgrade Script is failing with NPE
URL: https://github.com/apache/hive/pull/667
 
 
   
 
----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


Issue Time Tracking
-------------------

            Worklog Id:     (was: 256578)
            Time Spent: 10m
    Remaining Estimate: 0h

> HMS schema Upgrade Script is failing with NPE
> ---------------------------------------------
>
>                 Key: HIVE-21844
>                 URL: https://issues.apache.org/jira/browse/HIVE-21844
>             Project: Hive
>          Issue Type: Task
>          Components: HiveServer2
>    Affects Versions: 4.0.0
>            Reporter: mahesh kumar behera
>            Assignee: mahesh kumar behera
>            Priority: Major
>              Labels: pull-request-available
>             Fix For: 4.0.0
>
>         Attachments: HIVE-21844.01.patch
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> schema upgrade tool is failing with NPE while executing "SELECT 'Upgrading MetaStore
schema from 1.2.0 to 2.0.0' AS ' '". The header row (metadata) is coming with rows having
value null. This is causing null pointer access in function TableOutputFormat::getOutputString
when row.values[i] is accessed. Instead of " AS ' ' ", if some other value  like "AS dummy"
is given, it's working fine. The issue is coming with mysql version 5.7 and above.
>  
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message