ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Woods <p...@woodsfamily.ws>
Subject update inside stored procedure
Date Tue, 04 Jan 2005 09:11:37 GMT
I thought I had a similiar problem to what the poster of
http://www.mail-archive.com/ibatis-user-java@incubator.apache.org/msg00135.html had, and I
tried the solution that worked for him, but without success.  After doing as suggested I am
not getting any exceptions, but there are no apparent updates being performed on the database

Just to verify, my transactionManager tag now looks like:
<transactionManager type="JDBC" commitRequired="true">
  ... datasource stuff ...

The procedure inside the sqlMap file is:
<procedure id="increment" parameterMap="incrementMap">
	{ call incProc(?, ?) }

I'm calling it with (update/insert threw exceptions for me):
sqlMap.queryForObject("increment", map);

I'm using postgresql 7.3, the stored procedure works fine when called
from psql.  I tried ibatis 2.0.8 w/o luck, and just saw and tried 2.0.9
w/ the same results.

Thanks for any help provided.  Love ibatis.

View raw message