i'm not sure about your "formAction" semantic. You should name it something meaningful like "removeFoo". The method names should be named after the actions that are taking place. But, yes you would follow the same semantic. You need to realize that JPetstore is NOT standard struts practice. It is a way to use struts in a more modern manner (i.e. Action has properties on it rather than sepearate in an ActionForm.). Otherwise, it sounds like you have the idea down fairly well. Brandon On 5/12/05, Lieven De Keyzer wrote: > I took the lastest JPetStore as a starting point for my application. > > The problem I have now: I want to have multiple actions in one form. I have > a set of objects belonging to a user and this are displayed together with a > checkbox for each object. I want the users to be able to check a few boxes > and let them choose to delete those, or edit them all at once, etc... > > Normall I think one should implement a class that inherits from the > DispatchAction Class. > > I guess using the BaseBean and BeanAction class, this should even be > simpler. Should I use the same tactic as the DispatchAction class uses ? > Something like: > > public Class TreeLevel extends BaseBean { > > private String method; > > public String formAction { > if (method == "foo") { > return foo(); } > else { return bar(); } > } > > private String foo() { > // > } > > private String bar() { > } > } > > And then in my jsp page: > > > > > > >