ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From navrsale <navrsalem...@yahoo.ca>
Subject Re: [2.2.0] Support for Oracle Ref Cursor
Date Wed, 08 Nov 2006 01:52:08 GMT

I changed params to correct order. I tried to use String directly in
resultMap but get error:

java.lang.RuntimeException: Error occurred.  Cause:
tException: Error parsing XML.  Cause: java.lang.RuntimeException: Error
 XPath '/sqlMapConfig/sqlMap'.  Cause:
com.ibatis.common.xml.NodeletException: E
rror parsing XML.  Cause: org.xml.sax.SAXParseException: <Line 115, Column
XML-20150: (Error) Element resultMap not complete, expected elements

It seems I have to specify class (cannot use String for example, to directly
map). I also tried to use "resultClass"
syntax but got error...

If I could use String class directly in resultMap, maybe I could get result
set from cursor open on Oracle type instead of table, something like:

<resultMap class="String" id="report_line_mapping">

Not sure what is inline syntax, though. Is there an example?

Jeff Butler-2 wrote:
> It's not just random - the parameters you supply must match what's
> required
> by your procedure.  In the example you gave, you had syntax like this:
>  { ? = call ipgrouper_it2.load_validation.get_post_validation_report( ? )}
> This implies that the first parameter (the first question mark) is an OUT
> parameter, and the second parameter is either IN or INOUT.
> It might be clearer if you stopped using explicit parameter maps and used
> the inline syntax instead.
> Jeff Butler
> On 11/7/06, navrsale <navrsalemile@yahoo.ca> wrote:
>> I investigated further. I tried different combinations, with stored
>> procedure
>> (one IN, one OUT parameter) and stored function (one IN parameter). None
>> of
>> these combinations works. Either I get empty result set, or error
>> complaining about number or type of parameters for stored procedure. It
>> could be that Wiki example works as there are no input parameters to
>> stored
>> function (I didn't try that because in my example I need input
>> parameter).
>> In all of these examples I tried with ref cursor on physical table, just
>> like in Wiki examples. But none of these combinations works. It seems
>> Oracle
>> ref cursors are not supported in current version if stored function has
>> IN
>> parameter or if it is stored procedure.
>> If anybody has some other suggestions or hints please let me know..

View this message in context: http://www.nabble.com/-2.2.0--Support-for-Oracle-Ref-Cursor-tf2167822.html#a7231391
Sent from the iBATIS - User - Java mailing list archive at Nabble.com.

View raw message