ibatis-user-java mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yee, Richard K CTR DMDC" <Richard.Yee....@osd.pentagon.mil>
Subject RE: issue with unknown host exception
Date Tue, 06 Feb 2007 17:58:41 GMT
I believe I sent you the wrong DOCTYPE. I sent you the one for the sqlmap
config instead of the sqlMap file
Try this one.
<!DOCTYPE sqlMap

PUBLIC "-//ibatis.apache.org//DTD SQL Map 2.0//EN"


Which version of iBATIS are you using. This DOCTYPE is for versions after



-----Original Message-----
From: Ashish Kulkarni [mailto:ashish.kulkarni13@gmail.com] 
Sent: Tuesday, February 06, 2007 9:25 AM
To: user-java@ibatis.apache.org; lmeadors@apache.org
Subject: Re: issue with unknown host exception

I tried changing it to 
<!DOCTYPE sqlMap                                         
PUBLIC "-//ibatis.apache.org//DTD SQL Map Config 2.0//EN"
"  <http://ibatis.apache.org/dtd/sql-map-2.dtd>

But still i get the same error, i have java 1.4.2 on this AS400, so the XML
parser must be from java.

Also i have these program running on 5 other AS400 boxes with same jar
files, but not working on this one, 

i tried to ping http://ibatis.apache.org <http://ibatis.apache.org>  but it
could not find the server.

how do i change it to use system DTD instead of the default.

Do you have an example.


On 2/6/07, Larry Meadors <lmeadors@apache.org <mailto:lmeadors@apache.org> >

It should be resolved in the iBATIS jar file. Are you using an older
version of iBATIS, or the current release?

Also, it could be the XML parser on the 400..if that is the case, you
could use a system DTD instead of the default. 


On 2/6/07, Ashish Kulkarni <ashish.kulkarni13@gmail.com
<mailto:ashish.kulkarni13@gmail.com> > wrote:
> Hi
> I have a java program which uses ibatis to run SQL queries, this program 
> runs on AS400, and on of the AS400 boxes i am getting following error
> Error occurred.  Cause:
> com.ibatis.common.xml.NodeletException: Error parsing XML.
> Caused by: java.net.UnknownHostException : ibatis.apache.org
> The header in my XML file looks like this
> <?xml version="1.0" encoding="UTF-8" ?>
> <!DOCTYPE sqlMapConfig 
> PUBLIC "-//iBATIS.com//DTD SQL Map Config 2.0//EN"
> " http://ibatis.apache.org/dtd/sql-map-config-2.dtd
<http://ibatis.apache.org/dtd/sql-map-config-2.dtd> ">
> i suspect this AS400 has a firewall which blocks all internet traffic. 
> Is this the cause of this problem, is there any work around to get it
> working on this AS400 machine?
> Regards
> Ashish

View raw message