ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dmitriy Setrakyan <dsetrak...@apache.org>
Subject Loading vs. Preloading
Date Sun, 01 Mar 2015 10:32:40 GMT

We have a concept of DataLoader which is responsible for loading large
amounts of data into caches. We also have a concept of "preloading" which
is responsible for the data rebalancing which happens in the background.

I think the naming for data-loading and preloading is too close and gets
confusing. How about we renaming preloading to rebalancing? This would
rename CachePreloadMode to CacheRebalanceMode. A bunch of preloading
configuration properties will have to be renamed too (configuration
properties are documented here:

Again, I am trying to finalize all API changes before resubmitting RC1 for
a vote.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message