ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anton Vinogradov <avinogra...@gridgain.com>
Subject Re: Coding style changed!
Date Wed, 02 Sep 2015 13:43:52 GMT
Problem fixed using top secret -XDenableSunApiLintControl param.
Thanks for stopping me :)

On Wed, Sep 2, 2015 at 3:30 PM, Anton Vinogradov <avinogradov@gridgain.com>
wrote:

> I did not found how to do that, will try to search again.
>
>
> On Wed, Sep 2, 2015 at 3:01 PM, Sergi Vladykin <sergi.vladykin@gmail.com>
> wrote:
>
>> Can we ignore this this type of warning in JavaDoc checker?
>> I don't like the idea of having some special imports because of that.
>>
>> Sergi
>>
>> 2015-09-02 14:32 GMT+03:00 Anton Vinogradov <avinogradov@gridgain.com>:
>>
>> > .. I mean at Ignite Javadoc
>> >
>> > On Wed, Sep 2, 2015 at 2:31 PM, Anton Vinogradov <
>> avinogradov@gridgain.com
>> > >
>> > wrote:
>> >
>> > > Because we should have no mistakes at Ignite Java.
>> > > Checking that build logs contains no "Javadoc Warnings" helps to
>> > guarantee
>> > > that.
>> > >
>> > > On Wed, Sep 2, 2015 at 2:02 PM, Sergi Vladykin <
>> sergi.vladykin@gmail.com
>> > >
>> > > wrote:
>> > >
>> > >> I think these warnings are valid, since we are really using
>> proprietary
>> > >> APIs like Unsafe.
>> > >> Why should we hide them?
>> > >>
>> > >> Sergi
>> > >>
>> > >> 2015-09-01 16:29 GMT+03:00 Anton Vinogradov <
>> avinogradov@gridgain.com>:
>> > >>
>> > >> > Hello,
>> > >> >
>> > >> > Since codestyle was changed javadoc starts to warn about using
of
>> > >> > proprietary API.
>> > >> >
>> > >> > For example:
>> > >> > Javadoc Warnings
>> > >> >
>> > >> >
>> > >>
>> >
>> ignite/modules/core/src/main/java/org/jsr166/ConcurrentLinkedDeque8.java:29:
>> > >> > warning: Unsafe is internal proprietary API and may be removed
in a
>> > >> future
>> > >> > release
>> > >> > import sun.misc.Unsafe;
>> > >> >
>> > >> > Using import sun.misc.* solves this problem. IDEA codestyle can
be
>> > >> > configured to use implicit imports for specified packages.
>> > >> > Specifying sun.misc, sun.nio.ch, com.sun.jmx.mbeanserver fixed
>> build
>> > >> > output.
>> > >> >
>> > >> > Does anybody know other way to suspend this warning without
>> suspending
>> > >> > others?
>> > >> >
>> > >> >
>> > >> > On Tue, Sep 1, 2015 at 9:21 AM, Denis Magda <dmagda@gridgain.com>
>> > >> wrote:
>> > >> >
>> > >> > > I've updated '{ignite_folder}/idea/ignite_codeStyle.xml'
to
>> reflect
>> > >> the
>> > >> > > changes.
>> > >> > >
>> > >> > > --
>> > >> > > Denis
>> > >> > >
>> > >> > >
>> > >> > > On 8/31/2015 5:48 PM, Sergi Vladykin wrote:
>> > >> > >
>> > >> > >> Guys,
>> > >> > >>
>> > >> > >> As discussed, I changed all the imports in master to
explicit
>> ones.
>> > >> > >>
>> > >> > >> Settings for Idea you can see here:
>> > >> > >>
>> > >> > >>
>> > >> >
>> > >>
>> >
>> https://issues.apache.org/jira/secure/attachment/12753298/Screen%20Shot%202015-08-31%20at%202.18.27%20PM.png
>> > >> > >>
>> > >> > >> Coding guidelines will be updated soon.
>> > >> > >>
>> > >> > >> Sergi
>> > >> > >>
>> > >> > >>
>> > >> > >
>> > >> >
>> > >>
>> > >
>> > >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message