ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valentin Kulichenko <valentin.kuliche...@gmail.com>
Subject CacheLoadOnlyStoreAdapter
Date Sat, 12 Dec 2015 00:32:25 GMT

We have a class that is called CacheLoadOnlyStoreAdapter. This is a cache
store adapter that implements utility logic for multithreaded data loading,
so that user has to provide only the logic that queries DB and parses DB
row into object. Everything else is done automatically.

It's a cool feature, but the name looks really confusing to me. It's
definitely not 'load-only' store, because it implements CacheWriter.

How about we rename it to CacheMultithreadedLoadStoreAdapter? Any other


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message