ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vyacheslav Daradur <daradu...@gmail.com>
Subject Re: IGNITE-4374 - Ignite should validate JVM and OS configuration and output warning in log
Date Wed, 28 Dec 2016 09:29:52 GMT
Yakov, I have looked at source codes and I agree with you.

Let's rename GridPerformanceSuggestions to ConfigurationSuggestions
and to add new checks to suggestOptimizations method in IgniteKernal or
separate method.

2016-12-27 14:51 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com>:

> I mean ConfigurationValidator as another class, not
> GridPerformanceSuggestion.
>
> And invoke it from IgniteKernal.
>
> 2016-12-27 14:46 GMT+03:00 Vyacheslav Daradur <daradurvs@gmail.com>:
>
>> >>
>> 3. I think this should be a new section in performance suggestion output.
>> And I think the GridPerformanceSuggestions should be used, but it should
>> be
>> probably renamed to reflect its new role and remove Grid prefix also. How
>> about ConfigurationSuggestions?
>> >>
>> How about:
>>
>> public class ConfigurationValidator {
>>
>>       public static String getPerformanceSuggestions() {...}
>>
>>       public static List<String> getPerformanceSuggestions() {...}
>>
>> }
>>
>>
>>
>>
>> 2016-12-27 14:12 GMT+03:00 Yakov Zhdanov <yzhdanov@apache.org>:
>>
>>> Vyacheslav, my comments are below.
>>>
>>> >>
>>> 1. It is necessary to check a flag MaxDirectMemorySize, but there is no
>>> recommendation of it:
>>> https://apacheignite.readme.io/docs/jvm-and-system-tuning
>>>
>>> 2. Whether it is necessary to output message in "Quiet mode"?
>>>
>>> 3. Where it is better to output information about checking? At the end or
>>> maybe before "Ignite node started OK"?
>>> >>
>>>
>>> 1. Alex Goncharuk, can you please help here? How can we determine how
>>> much
>>> direct memory we need? Vyacheslav, you can skip this for the very first
>>> version.
>>>
>>> 2. Yes
>>>
>>> 3. I think this should be a new section in performance suggestion output.
>>> And I think the GridPerformanceSuggestions should be used, but it should
>>> be
>>> probably renamed to reflect its new role and remove Grid prefix also. How
>>> about ConfigurationSuggestions?
>>>
>>> --Yakov
>>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message