ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Novikov <anovi...@apache.org>
Subject Re: Issues with local deployment of the Web Console
Date Thu, 02 Feb 2017 04:04:30 GMT
Hi Prachi,

Thanks for your investigation. I found that Web Console download latest
released version of dependencies and this error occurred after Angular
library updated in repository to incompatible version.

This problem was already fixed in "master" branch. As temporary workaround
in your branch, you may  replace "^1.5.5" to "~1.5.5" in
"modules/web-console/frontend/package.json" and then execute in console
"npm update --no-optional" in "modules/web-console/frontend" folder.


On Thu, Feb 2, 2017 at 7:10 AM, Prachi Garg <pgarg@gridgain.com> wrote:

> Looks like I can't attach images to dev list. I have uploded the images
> here -
> https://drive.google.com/drive/folders/0B13J0oQz4pZxZThkUlJfMWJhTGM?
> usp=sharing
>
> On Wed, Feb 1, 2017 at 3:11 PM, Prachi Garg <pgarg@gridgain.com> wrote:
>
> > Engineers,
> >
> > I deployed the Web Console locally, and found a couple of issues while
> > trying to add and save a cluster on http://localhost:9000/configur
> > ation/clusters page-
> >
> >    1. There is no Java/XML code, on the right side.
> >    2. No list of cluster names.
> >    3. No 'undo' arrow/icon on the red button next to 'Save'
> >    4. No green notification, on top right of the screen, for successfully
> >    saving a cluster
> >    5. I keep getting the notification/warning popup box for unsaved
> >    changes although the log shows that a cluster is saved.
> >    6. I have to manually refresh the page to see some of the updates.
> >    7. I see some, not all, of the above mentioned issues when trying to
> >    add and save a cache.
> >    8. There is no Java or XML code on the Summary page.
> >
> > Please see the attached images and the log below:
> >
> > POST /configuration/clusters/save 400 13.376 ms - 44
> >
> > POST /configuration/clusters/save 400 11.070 ms - 44
> >
> > POST /configuration/clusters/save 400 10.033 ms - 44
> >
> > POST /configuration/caches/save 400 8.311 ms - 41
> >
> > POST /configuration/caches/save 400 7.587 ms - 41
> >
> >
> > I followed this documentation for local deployment -
> > https://apacheignite.readme.io/docs/local-deployment.
> >
> > Thanks,
> >
> > -Prachi
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message