ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Earle Nietzel <ea...@longsight.com.INVALID>
Subject Re: Updated libs for ignite-hibernate_4.2
Date Fri, 12 Jun 2020 16:26:44 GMT
Yep I completely understand just asking if someone can nudge gridgain to
release the newer artifacts!

-earle


On Fri, Jun 12, 2020 at 11:20 AM Denis Magda <dmagda@apache.org> wrote:

> Earle,
>
> Due to the LGPL license constraints, we (the Ignite community) cannot
> release binary artifacts of those LGPL libraries including Hibernate. So,
> you will always need to build those on libraries on your own. If that
> becomes a big deal, then use the binaries produced by GridGain that are
> available for their community edition.
>
> Let me know if I misunderstood your question.
>
> -
> Denis
>
>
> On Fri, Jun 12, 2020 at 6:50 AM Earle Nietzel <earle@longsight.com.invalid
> >
> wrote:
>
> > Hi Denis,
> >
> > I am referring to lgpl lib that gridgain has released here:
> >
> >
> https://gridgainsystems.com/nexus/content/repositories/external/org/apache/ignite/ignite-hibernate_4.2/
> >
> >
> https://gridgainsystems.com/nexus/content/repositories/external/org/apache/ignite/ignite-hibernate_5.1/
> >
> > The ignite documentation tells you to build them with -Prelease,lgpl
> which
> > is fine locally but it becomes a hassle, for example:
> > 1) explain to other developers you need to check out and perform a build
> of
> > this other project first
> > 2) same for continuous integrations as they fail for the same reason
> >
> > Basically a host of issues that come with missing artifacts...
> >
> > Thanks for any help with this,
> > -earle
> >
> >
> > On Thu, Jun 11, 2020 at 5:14 PM Denis Magda <dmagda@apache.org> wrote:
> >
> > > Hi Earle,
> > >
> > > As I can see ignite-hibernate_4.2 already uses the latest stable
> version
> > of
> > > Hibernate 4.2:
> > >
> > > <dependency>
> > >     <groupId>org.hibernate</groupId>
> > >     <artifactId>hibernate-core</artifactId>
> > >     <version>4.2.21.Final</version>
> > > </dependency>
> > >
> > >
> > > What's your version of Hibernate? Are you suggesting to support
> Hibernate
> > > 5.4?
> > >
> > > Just in case, there is a version of the integration for Hibernate 5.1
> and
> > > 5.3. You need to use ignite-hibernate_5.1 and ignite-hibernate_5.3
> > > artifacts for those.
> > >
> > > -
> > > Denis
> > >
> > >
> > > On Thu, Jun 11, 2020 at 11:24 AM Earle Nietzel
> > <earle@longsight.com.invalid
> > > >
> > > wrote:
> > >
> > > > Hello,
> > > >
> > > > I apologize for posting this here but was noticing that the maven lib
> > > >       <dependency>
> > > >         <groupId>org.apache.ignite</groupId>
> > > >         <artifactId>ignite-hibernate_4.2</artifactId>
> > > >         <version>${ignite.version}</version>
> > > >       </dependency>
> > > >
> > > > hasn't been updated in a while is there by any chance someone here
> > might
> > > be
> > > > able to nudge someone to release some updated libs.
> > > >
> > > > The last version was
> > > > ignite-hibernate_4.2-2.7.2.jar Wed Feb 06 14:17:29 MST 2019
> > > > would like to get a 2.8.1 if possible?
> > > >
> > > > Thanks,
> > > > -earle
> > > >
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message