ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Valentin Kulichenko <valentin.kuliche...@gmail.com>
Subject Re: [VOTE] Release Apache Ignite 3.0.0-alpha1 RC2
Date Tue, 05 Jan 2021 17:34:51 GMT
Hi Ilya,

Please see my comments below.

-Val

On Tue, Jan 5, 2021 at 2:09 AM Ilya Kasnacheev <ilya.kasnacheev@gmail.com>
wrote:

> Hello!
>
> -1 (binding)
>
> After doing mvn clean install, the modules/cli/target/ignite executable
> file is malformed, it would not run.
>
> When running it with zsh, the following error is seen:
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/modules/cli/target% ./ignite
> ./ignite: 17: set: Illegal option -o pipefail
>
> When running it with another popular shell, fish, the following error is
> seen:
> ikasnacheev@ikasnacheev-ThinkPad-P51s ~/D/a/m/c/target> ./ignite
> Failed to execute process './ignite'. Reason:
> exec: Exec format error
> The file './ignite' is marked as an executable but could not be run by the
> operating system.
>
> The reason for this, the file starts with Apache license, and then the
> #!/usr/bin/env marker is seen.
> However, by UNIX conventions, the shebang line has to be the very first.
> And only then you can specify the license.
>
> I would have thought that it will finally run as explicit bash script, but
> it won't either:
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/modules/cli/target% bash ignite
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/modules/cli/target% echo $?
> 1
>
> It won't even run as "bash ignite" even if you log in to bash first. The
> only way of running it is doing ./ignite while in bash.
>

Which OS are you running on? The tool was quite rigorously tested on bash
under Ubuntu and MacOS. I'm not sure about other shells though, will check.

Either way, does moving the env marker to the top help under all those
shells? If that's the case, the fix is easy and it might make sense to
include it and restart the vote. Please let me know if you have the fix.


> This aside, I don't really understand how we are going to publish this
> release. Will we offer downloads from ignite.apache.org? What if people
> start actually downloading it and see that it basically does nothing?
> Do we have documentation for this release? README.md is a one-liner.
> DEVNOTES.md does not even explain how to run it. There's `./docs' but no
> explanation how to use them. I have tried to go through the "Getting
> started" in the docs but also has failed miserably:
> ~/Downloads/apache-ignite-3.0.0-alpha1-src% mkdir ignite3 && cd ignite3
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/ignite3% curl -L "
>
> https://www.apache.org/dyn/mirrors/mirrors.cgi?action=download&filename=ignite/3.0.0-alpha1/ignite
> "
> -o ignite && chmod +x ignite
>
>  % Total    % Received % Xferd  Average Speed   Time    Time     Time
>  Current
>                                 Dload  Upload   Total   Spent    Left
>  Speed
>  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--
>     0
> 100  1017    0  1017    0     0   1040      0 --:--:-- --:--:-- --:--:--
>  1040
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/ignite3% ls
> ignite
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/ignite3% ./ignite
> ./ignite: 2: Syntax error: newline unexpected
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/ignite3% head ignite
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
>  "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
> <html xmlns="http://www.w3.org/1999/xhtml" lang="en" xml:lang="en">
> <head>
> <title>Object not found!</title>
> <link rev="made" href="mailto:%5bno%20address%20given%5d" />
> <style type="text/css"><!--/*--><![CDATA[/*><!--*/
>
> Alpha releases are usually the ones which contain the core functionality.
> The ones which aren't are called "technology preview" and should not carry
> the "apache ignite" brand in my opinion. Can we rename the deliverable to
> "apache ignite launcher 3.0.0 preview" or something like that? I would also
> very much like to have a tutorial on how to use it.
>

This has been discussed here:
http://apache-ignite-developers.2346864.n4.nabble.com/DISCUSSION-3-0-0-Alpha-release-td50744.html.
There were no objections, so I went on with the release. Actually, anything
that we publish must be a part of an Apache Ignite release, so what you're
suggesting is not possible anyway - it goes against legal requirements.

However, I certainly agree that we need to clearly explain what this alpha
build is for. We will have the disclaimer on the downloads page, as well as
in the documentation which will be published. The Getting Started guide
didn't work for you because the download link is not active yet - the
version needs to be released first.


>
> Also, if you try to build it with JVM 8, you will get a cryptic error:
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile
> (default-compile) on project ignite-configuration: Fatal error compiling:
> invalid flag: --release
> -> [Help 1]
>
> If you try to run it with JVM 8 (by logging in to bash first), you will get
> another cryptic error:
> ikasnacheev@ikasnacheev-ThinkPad-P51s:
> ~/Downloads/apache-ignite-3.0.0-alpha1-src/modules/cli/target$ ./ignite
> Error: A JNI error has occurred, please check your installation and try
> again
> Exception in thread "main" java.lang.UnsupportedClassVersionError:
> org/apache/ignite/cli/IgniteCliApp has been compiled by a more recent
> version of the Java Runtime (class file version 55.0
> ), this version of the Java Runtime only recognizes class file versions up
> to 52.0
>        at java.lang.ClassLoader.defineClass1(Native Method)
>
> I think that both pathways should check the JVM version explicitly.
>

This is a known issue that will be fixed in the next release:
https://issues.apache.org/jira/browse/IGNITE-13920


>
> Regards,
> --
> Ilya Kasnacheev
>
>
> вт, 5 янв. 2021 г. в 06:51, Denis Magda <dmagda@apache.org>:
>
> > +1 (binding)
> >
> > On Monday, January 4, 2021, Valentin Kulichenko <
> > valentin.kulichenko@gmail.com> wrote:
> >
> > > Dear Community,
> > >
> > > The release candidate is uploaded here:
> > > https://dist.apache.org/repos/dist/dev/ignite/3.0.0-alpha1-rc2/
> > > Maven staging:
> > >
> https://repository.apache.org/content/repositories/orgapacheignite-1503/
> > > Git tag: https://github.com/apache/ignite-3/tree/3.0.0-alpha1-rc2
> > >
> > > For more information on the purpose and the scope of the release, see
> > this
> > > discussion:
> > > http://apache-ignite-developers.2346864.n4.nabble.
> > > com/DISCUSSION-3-0-0-Alpha-release-td50744.html
> > >
> > > Included Jira tickets:
> > >
> https://issues.apache.org/jira/issues/?jql=project%20%3D%20IGNITE%20AND%
> > > 20fixVersion%20%3D%203.0.0-alpha1
> > >
> > > Fixes included on top of 3.0.0-alpha1 RC1:
> > >
> > >    - https://issues.apache.org/jira/browse/IGNITE-13950
> > >    (IgniteCliInterfaceTest can fail on Windows)
> > >
> > > DEVNOTES:
> > > https://github.com/apache/ignite-3/blob/3.0.0-alpha1-rc2/DEVNOTES.md
> > > <https://github.com/apache/ignite-3/blob/3.0.0-alpha1-rc1/DEVNOTES.md>
> > >
> > > The vote is formal, see voting guidelines:
> > > https://www.apache.org/foundation/voting.html
> > >
> > > +1 - accept Apache Ignite 3.0.0-alpha1 RC2
> > > 0 - don't care either way
> > > -1 - DO NOT accept Apache Ignite 3.0.0-alpha1 RC2 (explain why)
> > >
> > > See notes on how to verify release here:
> > > https://www.apache.org/info/verification.html
> > >
> > > This vote will be open for 72 hours and will close on January 8th at
> > 12:00
> > > am UTC:
> > >
> >
> https://www.timeanddate.com/countdown/generic?iso=20210107T16&p0=224&font=
> > > cursive
> > >
> > > -Val
> > >
> >
> >
> > --
> > -
> > Denis
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message