ignite-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Daschinsky <ivanda...@gmail.com>
Subject Re: Ignite website css not loading in local dev
Date Mon, 01 Feb 2021 07:49:08 GMT
Saikat, have you tried build and run locally docs using docker? I just
tried latest master -- everything is working as expected.
Checked this in chrome incognito mode. I usually check docs locally using
these steps:
1 cd docs
2. docker run -v "$PWD:/srv/jekyll" -p 4000:4000 jekyll/jekyll:latest
jekyll s
3. Go to http://0.0.0.0:4000/docs/ in chrome incognito tab.

пн, 1 февр. 2021 г. в 07:09, Denis Magda <dmagda@apache.org>:

> Saikat,
>
> Attach the screenshot with what you see. Please also check what errors the
> browser is printing out while rendering the page.
>
> You don't need to install Jekyll unless you build the docs locally. So,
> skip this step. Also, you don't need to uncomment the "include virtual".
>
> -
> Denis
>
>
> On Sun, Jan 31, 2021 at 1:35 PM Saikat Maitra <saikat.maitra@gmail.com>
> wrote:
>
> > Hi Denis, Ivan
> >
> > Thank you for your email. I have verified the below lines in httpd.conf
> >
> > AddType text/html .html
> > AddOutputFilter INCLUDES .html
> >
> > I have also pull latest changes from master.
> >
> > I still see the issue in local, let me check if I need to make any
> > other changes.
> >
> > Also another change I did is I omitted the /trunk path from the Document
> > root and used path till ignite-website since we are no longer using svn.
> >
> > I have a question related to Jekyll, do I need to install Jekyll to run
> the
> > website in local?
> >
> > Also I have observed few additional lines commented in the index.html
> like
> > below
> >
> > <!--#include virtual="/includes/header.html" -->
> >
> > I will check if uncommenting them addresses the issue.
> >
> > Regards,
> > Saikat
> >
> >
> >
> > On Sun, Jan 31, 2021 at 12:08 PM Ivan Daschinsky <ivandasch@gmail.com>
> > wrote:
> >
> > > Hi, Saikat. Do you have
> > https://issues.apache.org/jira/browse/IGNITE-13659
> > > commit in yout local branch?
> > > In this patch, this issue was solved. Namely, docs/assets/css/docs.scss
> > > and docs/assets/css/styles.scss are corrected.
> > > Jekyll required that in custom stiles, first two lines contains this
> char
> > > sequence `---`
> > >
> > > вс, 31 янв. 2021 г. в 03:09, Denis Magda <dmagda@apache.org>:
> > >
> > > > Hi Saikat,
> > > >
> > > > Please double check that you configured the Apache server strictly
> > > > following steps 3-5. As far as I remember, I had the exact CSS issue
> > > until
> > > > did this (step 5):
> > > >
> > > > AddType text/html .html
> > > > AddOutputFilter INCLUDES .html
> > > >
> > > >
> > > > -
> > > > Denis
> > > >
> > > >
> > > > On Sat, Jan 30, 2021 at 1:38 PM Saikat Maitra <
> saikat.maitra@gmail.com
> > >
> > > > wrote:
> > > >
> > > > > Hi,
> > > > >
> > > > > I was working on updating the ignite-website page[1] for Ignite
> > > > Extensions
> > > > > and I observed that in local when we are running the ignite-website
> > > then
> > > > it
> > > > > is not loading the css.
> > > > >
> > > > > I have followed the instructions as mentioned  in confluence
> page[2]
> > > > >
> > > > > [1] https://ignite.apache.org/features/streaming.html
> > > > > [2]
> > > >
> https://cwiki.apache.org/confluence/display/IGNITE/Website+Development
> > > > >
> > > > > Are there any additional steps that need to be done?
> > > > >
> > > > > I also noted that the source in live website pages vs the local is
> > > > > different in terms of js and css files.
> > > > >
> > > > > Regards,
> > > > > Saikat
> > > > >
> > > >
> > >
> > >
> > > --
> > > Sincerely yours, Ivan Daschinskiy
> > >
> >
>


-- 
Sincerely yours, Ivan Daschinskiy

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message