jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-304) Rename ContentSession.getCurrentRoot() to getCurrentHeadRoot()
Date Fri, 14 Sep 2012 10:57:07 GMT

    [ https://issues.apache.org/jira/browse/OAK-304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13455720#comment-13455720

Michael Dürig commented on OAK-304:

Ok lets settle for {{getLatestRoot()}} then and not introduce new terminology.
> Rename ContentSession.getCurrentRoot() to getCurrentHeadRoot()
> --------------------------------------------------------------
>                 Key: OAK-304
>                 URL: https://issues.apache.org/jira/browse/OAK-304
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Assignee: Thomas Mueller
>         Attachments: OAK-304.patch
> Renaming the method would make it clear that the method is potentially expensive and
the returned object reflects the head of the repository at the time the method is called.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message