jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-304) Rename ContentSession.getCurrentRoot() to getCurrentHeadRoot()
Date Fri, 14 Sep 2012 10:53:07 GMT

    [ https://issues.apache.org/jira/browse/OAK-304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13455716#comment-13455716

Jukka Zitting commented on OAK-304:

The term "head" is currently not used anywhere above the MicroKernel. I'd rather not introduce
the term but if we want to do so, I'd simply name the method getHead(), with the definition
that the "head" is the "latest root".
> Rename ContentSession.getCurrentRoot() to getCurrentHeadRoot()
> --------------------------------------------------------------
>                 Key: OAK-304
>                 URL: https://issues.apache.org/jira/browse/OAK-304
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>            Reporter: Thomas Mueller
>            Assignee: Thomas Mueller
>         Attachments: OAK-304.patch
> Renaming the method would make it clear that the method is potentially expensive and
the returned object reflects the head of the repository at the time the method is called.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message