jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] [Commented] (OAK-563) Rename SessionDelegate...OrThrow methods
Date Thu, 17 Jan 2013 15:12:25 GMT

    [ https://issues.apache.org/jira/browse/OAK-563?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13556256#comment-13556256

Michael Dürig commented on OAK-563:

Having another look at this, what strikes me as odd is {{SessionDelegate.getOakPathOrThrowNotFound()}}.
Throwing a {{PathNotFoundException}} when path conversion fails (most likely due to a non
existing name space mapping) seems wrong to me. Furthermore all usages of this method handle
the case where the converted path does not exist later on in some way or another. I'd suggest
to get rid of this method entirely and us the {{getOakPathOrThrow()}} method instead, which
throws a more generic {{RepositoryException}} with a correct error message. 
> Rename SessionDelegate...OrThrow methods
> ----------------------------------------
>                 Key: OAK-563
>                 URL: https://issues.apache.org/jira/browse/OAK-563
>             Project: Jackrabbit Oak
>          Issue Type: Improvement
>          Components: core
>            Reporter: Michael Dürig
>            Assignee: Michael Dürig
>             Fix For: 0.6
> As a fallout of OAK-553 there are some inconsistency in method naming in {{SessionDelegate}}
now. We should align the names of the ...OrThrow methods. That is, drop the OrThrow suffixes.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message