jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Reschke (JIRA)" <j...@apache.org>
Subject [jira] [Created] (OAK-4078) 1.2 branch can't use latest stable Jackrabbit release
Date Tue, 01 Mar 2016 11:02:18 GMT
Julian Reschke created OAK-4078:
-----------------------------------

             Summary: 1.2 branch can't use latest stable Jackrabbit release
                 Key: OAK-4078
                 URL: https://issues.apache.org/jira/browse/OAK-4078
             Project: Jackrabbit Oak
          Issue Type: Bug
          Components: security
    Affects Versions: 1.2.11
            Reporter: Julian Reschke


When updating the parent pom to use the latest Jackrabbit release from the 2.10 branch (2.10.1),
the following build problem surfaces:

{noformat}
[ERROR] C:\projects\apache\oak\1.2\oak-core\src\main\java\org\apache\jackrabbit\oak\security\user\autosave\AutoSaveEnabledManager.java:[56,7]
org.apache.jackrabbit.oak.security.user.autosave.AutoSaveEnabledManager is not abstract and
does not override abstract method <T>getAuthorizable(java.lang.String,java.lang.Class<T>)
in org.apache.jackrabbit.api.security.user.UserManager
[ERROR] C:\projects\apache\oak\1.2\oak-core\src\main\java\org\apache\jackrabbit\oak\security\user\UserManagerImpl.java:[66,7]
org.apache.jackrabbit.oak.security.user.UserManagerImpl is not abstract and does not override
abstract method <T>getAuthorizable(java.lang.String,java.lang.Class<T>) in org.apache.jackrabbit.api.security.user.UserManager
{noformat}

cc [~anchela]



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message