jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Jäggi (JIRA) <j...@apache.org>
Subject [jira] [Updated] (OAK-4155) oaj.oak.spi.security.authentication.credentials not exported
Date Wed, 30 Mar 2016 13:01:25 GMT

     [ https://issues.apache.org/jira/browse/OAK-4155?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dominique Jäggi updated OAK-4155:
---------------------------------
    Fix Version/s: 1.5.1
                   1.6

> oaj.oak.spi.security.authentication.credentials not exported
> ------------------------------------------------------------
>
>                 Key: OAK-4155
>                 URL: https://issues.apache.org/jira/browse/OAK-4155
>             Project: Jackrabbit Oak
>          Issue Type: Bug
>    Affects Versions: 1.6, 1.5.0
>            Reporter: Amit Jain
>             Fix For: 1.6, 1.5.1
>
>
> Unable to load oak-auth-external in osgi environments [1]. The package {{org.apache.jackrabbit.oak.spi.security.authentication.credentials}}

> does not have an entry in Export-package declaration in the pom though it has a export
version of 1.0. 
> Adding the entry in the Export-package fixes the issue.
> [1]
> {noformat}
> 30.03.2016 14:53:15.040 *ERROR* [FelixDispatchQueue] org.apache.jackrabbit.oak-auth-external
FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-auth-external
[89](R 89.0): missing requirement [org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))
Unresolved requirements: [[org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-auth-external
[89](R 89.0): missing requirement [org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))
Unresolved requirements: [[org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))]
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
> 	at java.lang.Thread.run(Thread.java:745)
> 30.03.2016 14:53:15.040 *ERROR* [FelixDispatchQueue] org.apache.jackrabbit.oak-auth-ldap
FrameworkEvent ERROR (org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-auth-ldap
[90](R 90.0): missing requirement [org.apache.jackrabbit.oak-auth-ldap [90](R 90.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.external)(version>=2.0.0)(!(version>=3.0.0)))
[caused by: Unable to resolve org.apache.jackrabbit.oak-auth-external [89](R 89.0): missing
requirement [org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))]
Unresolved requirements: [[org.apache.jackrabbit.oak-auth-ldap [90](R 90.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.external)(version>=2.0.0)(!(version>=3.0.0)))])
> org.osgi.framework.BundleException: Unable to resolve org.apache.jackrabbit.oak-auth-ldap
[90](R 90.0): missing requirement [org.apache.jackrabbit.oak-auth-ldap [90](R 90.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.external)(version>=2.0.0)(!(version>=3.0.0)))
[caused by: Unable to resolve org.apache.jackrabbit.oak-auth-external [89](R 89.0): missing
requirement [org.apache.jackrabbit.oak-auth-external [89](R 89.0)] osgi.wiring.package; (&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.credentials)(version>=1.0.0)(!(version>=2.0.0)))]
Unresolved requirements: [[org.apache.jackrabbit.oak-auth-ldap [90](R 90.0)] osgi.wiring.package;
(&(osgi.wiring.package=org.apache.jackrabbit.oak.spi.security.authentication.external)(version>=2.0.0)(!(version>=3.0.0)))]
> 	at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:4111)
> 	at org.apache.felix.framework.Felix.startBundle(Felix.java:2117)
> 	at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1371)
> 	at org.apache.felix.framework.FrameworkStartLevelImpl.run(FrameworkStartLevelImpl.java:308)
> 	at java.lang.Thread.run(Thread.java:745)
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message