jackrabbit-oak-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julian Reschke (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (OAK-5455) Specify versions for maven plugins used in build for ensuring stable builds
Date Tue, 26 Sep 2017 14:11:02 GMT

    [ https://issues.apache.org/jira/browse/OAK-5455?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16180820#comment-16180820
] 

Julian Reschke commented on OAK-5455:
-------------------------------------

Current top level warnings are:

{noformat}
[INFO] The following plugin updates are available:
[INFO]   maven-assembly-plugin ................................ 3.0.0 -> 3.1.0
[INFO]   maven-surefire-plugin ................................ 2.20 -> 2.20.1
[INFO] 
[WARNING] The following plugins do not have their version specified:
[WARNING]   maven-compiler-plugin ...................................... 3.7.0
[WARNING]   maven-deploy-plugin ....................... (from super-pom) 2.8.2
[WARNING]   maven-failsafe-plugin ..................................... 2.20.1
[WARNING]   maven-javadoc-plugin .................................... 3.0.0-M1
[WARNING]   maven-release-plugin ...................... (from super-pom) 2.5.3
[WARNING]   maven-resources-plugin ..................................... 3.0.2
{noformat}

> Specify versions for maven plugins used in build for ensuring stable builds
> ---------------------------------------------------------------------------
>
>                 Key: OAK-5455
>                 URL: https://issues.apache.org/jira/browse/OAK-5455
>             Project: Jackrabbit Oak
>          Issue Type: Task
>          Components: parent
>            Reporter: Chetan Mehrotra
>            Assignee: Julian Reschke
>             Fix For: 1.8, 1.7.9
>
>         Attachments: enforce.diff, OAK-5455-v1.patch
>
>
> Running a check for plugin versions used in oak build 
> {noformat}
> mvn versions:display-plugin-updates
> {noformat}
> leads to following warning
> {noformat}
> [INFO] The following plugin updates are available:
> [INFO]   org.apache.felix:maven-scr-plugin .................. 1.16.0 -> 1.21.0
> [INFO] 
> [WARNING] The following plugins do not have their version specified:
> [WARNING]   maven-compiler-plugin ...................................... 2.0.2
> [WARNING]   maven-deploy-plugin ......................... (from super-pom) 2.4
> [WARNING]   maven-failsafe-plugin ..................................... 2.12.4
> [WARNING]   maven-jar-plugin ............................................. 2.1
> [WARNING]   maven-javadoc-plugin ......................................... 2.0
> [WARNING]   maven-release-plugin ................. (from super-pom) 2.0-beta-4
> [WARNING]   maven-resources-plugin ....................................... 2.2
> [WARNING]   maven-surefire-plugin ...................................... 2.4.2
> [INFO] 
> [WARNING] Project does not define minimum Maven version, default is: 2.0
> [INFO] Plugins require minimum Maven version of: 3.0.5
> [INFO] Note: the super-pom from Maven 3.3.9 defines some of the plugin
> [INFO]       versions and may be influencing the plugins required minimum Maven
> [INFO]       version.
> [INFO] 
> [ERROR] Project does not define required minimum version of Maven.
> [ERROR] Update the pom.xml to contain
> [ERROR]     <prerequisites>
> [ERROR]       <maven>3.0.5</maven>
> [ERROR]     </prerequisites>
> {noformat}
> As a fix we should
> # Specify version for all maven plugin in use
> # Specify minimum version of maven to be used (version used in CI is 3.2.1)
> # Configure enforcer plugin to ensure that in future no plugin is used without specifying
the version [1]
> [1] http://maven.apache.org/enforcer/enforcer-rules/requirePluginVersions.html



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message