jena-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From acoburn <...@git.apache.org>
Subject [GitHub] jena pull request #467: JENA-1599: Upgrade to jsonld-java 0.12.1
Date Wed, 05 Sep 2018 16:12:53 GMT
GitHub user acoburn opened a pull request:

    https://github.com/apache/jena/pull/467

    JENA-1599: Upgrade to jsonld-java 0.12.1

    This upgrades jsonld-java to the latest version. That version does not require an extra
import of Guava in an OSGi environment (Guava is shaded in jsonld-java, but the bundle manifest
was incorrect in 0.12.0), so the extra import can be removed from Jena's `feature.xml` file.
    
    Tested in Karaf 4.2.0 and 4.2.1 under JDK8 and JDK10. With JDK10, one will need to also
install `javax.annotation-api` in the Karaf console, but that is separate from this issue.


You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/acoburn/jena JENA-1599

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/jena/pull/467.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #467
    
----
commit 04f2c8a6a028633e27ae0d5c546b57b7c796c0c5
Author: Aaron Coburn <acoburn@...>
Date:   2018-09-05T15:57:58Z

    JENA-1599: Upgrade to jsonld-java 0.12.1

----


---

Mime
View raw message