jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: Rename "request_sent_retry_enabled" to retry_all_methods ?
Date Fri, 07 Apr 2017 16:45:19 GMT
On Fri, Apr 7, 2017 at 6:39 PM, sebb <sebbaz@gmail.com> wrote:

> On 7 April 2017 at 17:35, Philippe Mouawad <philippe.mouawad@gmail.com>
> wrote:
> > On Fri, Apr 7, 2017 at 6:30 PM, sebb <sebbaz@gmail.com> wrote:
> >
> >> On 7 April 2017 at 17:27, Philippe Mouawad <philippe.mouawad@gmail.com>
> >> wrote:
> >> > On Fri, Apr 7, 2017 at 10:44 AM, sebb <sebbaz@gmail.com> wrote:
> >> >
> >> >> If a user property is renamed, it may break some tests.
> >> >>
> >> > It was introduced only few days ago for tuukka.
> >>
> >> OK, in which case it can be renamed or deleted with impunity.
> >>
> > Do you think the new name is better  ? clearer for users ?
> >
> >
> >    - request_sent_retry_enabled
> >    - retry_all_methods
> >    - Or maybe retry_all_http_methods
>
> What does the property control?
>
The retry of requests that have already been sent (not idempotent). You can
read the mentioned thread.
The use case is a bit edgy (AWS LB) but I think it is useful for a lot of
use cases as Cloud deployments are increasing.

Excerpt:
--------------------------------------------------------------------------------------------------------
My problem is that AWS Application Load Balancer (ALB) terminates all
existing connections during configuration changes (including auto-scaling).
As my perf tests trigger auto-scaling, I want to retry failed requests that
ALB connection termination causes.

This results in a bunch of NoHttpResponseException whenever scaling occurs
(=when ALB terminates existing connections).

(And yeah, this load balancer behavior is weird and ugly but it's what they
confirmed).

--------------------------------------------------------------------------------------------------------



> >
> >
> >> >
> >> >>
> >> >> It is possible to rename, but you need to keep the old name as an
> >> >> alias for at least one revision, and usage of the old alias should
> >> >> generate a warning log message.
> >> >>
> >> >> On 6 April 2017 at 20:44, Philippe Mouawad <
> philippe.mouawad@gmail.com>
> >> >> wrote:
> >> >> > Hello,
> >> >> > As per discussion "JMeter 3.1 httpclient4.retrycount does not
> work" on
> >> >> user
> >> >> > mailing list,
> >> >> > do you think we should rename this property ?
> >> >> >
> >> >> > Thanks
> >> >> > Regards
> >> >>
> >> >
> >> >
> >> >
> >> > --
> >> > Cordialement.
> >> > Philippe Mouawad.
> >>
> >
> >
> >
> > --
> > Cordialement.
> > Philippe Mouawad.
>



-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message