jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Pokhilko <a...@ya.ru>
Subject Re: TestAction: Change its name to make it more meaningful
Date Sat, 31 Mar 2018 07:29:45 GMT
Hi,

"Test" sounds redundant to me. Everything we do in JMeter is a test. So
maybe just "Logical Action"?

--

Andrey Pokhilko

30.03.2018 18:15, UBIK LOAD PACK Support пишет:
> Hello,
>
> TestAction in JMeter is a very useful element but its name is misleading or
> not clear at all.
>
> Currently it allows:
>
>    - Pausing
>    - Stopping Test
>    - Stopping Test immediately
>    - Switching to next thread loop iteration
>    - We'll soon propose a patch to add:
>       - Switch to next iteration of current loop : : It will be equivalent
>       of "continue" in the the first parent loop that contains it
>       - Break current loop : It will break the first parent loop that
>       contains it, equivalent of "break" in algorithm
>
>
> When we provide training or discuss with JMeter beginners, TestAction is
> usually understood as something to debug or "test", and nobody thinks that
> is allows all this.
>
> Shouldn't it be renamed to something like:
>
>    - Test Logic Action
>    - Logical Action
>    - Test Logical Action
>    - Test Execution Modifier
>
>
>
> Regards
> UbikLoadPack Support Team
> <http://twitter.com/ubikloadpack>
>


Mime
View raw message