jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Sitnikov <sitnikov.vladi...@gmail.com>
Subject Re: [VOTE] Release JMeter 5.0 RC1
Date Sun, 09 Sep 2018 19:40:57 GMT
I've apache-jmeter-5.0.tgz (macOS 10.13.6), and
1) It is OK with Java 1.8
2) In Java 1.9 and 10 main menu disappears after I click "Help -> Create a
thread dump".  Menu re-appears when I click "JMeter -> About JMeter" (the
very first item that is
always there).  Well, thread dump collection from the UI is definitely not
a main use case, however I wonder if other actions could dodge the menu.
UI without menu is not fun.

3) It fails to start with Java 11: java.lang.module.FindException: Module
java.activation not found
There are 16 days until Java 11 is officially released. Do we really want
to ship Java11-incompatible JMeter?

It looks like we can just avoid adding "--add-modules java.activation" for
Java 11+
If I remove that, JMeter looks fine in Java 11 (of course send email
sampler won't work, however I think it is a valid trade-off).

The next point regarding Java11 is OpenJDK 11 does not bundle JavaFX, so
JavaFX-based renderers do not work with either.

I'm +0.5 re the release, however it is a bit strange to release a version
without (even partial) Java 11 support.

Minor issue: png files in docs/images/screenshots/changes/5.0 are not
optimized (they consume 1'480'400, and optimized ones would take 623'800)
It looks like we should run "find . -name '*.png' -print0 | xargs -0 -P8
-L1 pngquant --ext .png --force" once in a while

Vladimir

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message