jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Philippe Mouawad <philippe.moua...@gmail.com>
Subject Re: Gradle migration: dist contains duplicate versions of jars
Date Tue, 06 Aug 2019 13:11:28 GMT
On Tuesday, August 6, 2019, Vladimir Sitnikov <sitnikov.vladimir@gmail.com>
wrote:

> >Follow eclipse.md / Launching from Eclipse and you'll get the issue.
>
> That means there's no issue with "dist contains duplicate versions of
> jars".

yes, I formulated wrongly the bug report.
The issue is due to .classpath duplicates

> In other words, Gradle does not produce duplicate jars.
>
> Gradle's dependency management is very flexible.
> Currently it resolves "groovy-all version 2.4.15" to be used for
> compilation and "groovy-all version 2.4.16" to be used for runtime.
>
> I'm not sure if Eclipse is flexible enough to represent that, however the
> resulting .classpath
> files seem to include both versions with no clear separation which is
> which.


yes

>
> In the Ideal world, groovy-all should probably not be included to the
> compilation classpath
> (we don't expect to call low level Groovy APIs from JMeter's Java code).


ok by me

>
> Vladimir
>


-- 
Cordialement.
Philippe Mouawad.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message