jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manoranjan Panigrahi <Manoranjan.Panigr...@toshiba-tsip.com>
Subject StandardJMeterEngine does not execute the JMeter Script with include controller. skips Include controller step
Date Wed, 16 Oct 2019 06:39:45 GMT

Hi,

I have two JMeter scripts(.jmx), in which first script is included as a Test fragment to the
second script.
When I run the script from GUI mode it runs fine. But When I run the script using TestNG,
the include controller part of the script is excluded.

Please help.

Script flow:
==========
First Script :
        TestPlan
             |------TestFragment
                                 |---------Test Elements
                                 |---------Samplers etc 

Second Script :
        TestPlan
             |------ Test Elements
             |------ThreadGroups
                                 |---------IncludeControler(Contains path and name of First
Script)
             |---------ThreadGroups
                                 |---------OtherElements

TestNG Execution Code:
=================
		File JmxFile1 = new File(System.getenv("$ScriptPath/SecondScript.jmx");
		HashTree testPlanTree = SaveService.loadTree(JmxFile1);
		jmeter.configure(testPlanTree);
		

JMeter Version used:3.3	

Regards,
Manoranjan
The information contained in this e-mail message and in any
attachments/annexure/appendices is confidential to the 
recipient and may contain privileged information. 
If you are not the intended recipient, please notify the
sender and delete the message along with any 
attachments/annexure/appendices. You should not disclose,
copy or otherwise use the information contained in the
message or any annexure. Any views expressed in this e-mail 
are those of the individual sender except where the sender 
specifically states them to be the views of 
Toshiba Software India Pvt. Ltd. (TSIP),Bangalore.

Although this transmission and any attachments are believed to be
free of any virus or other defect that might affect any computer 
system into which it is received and opened, it is the responsibility
of the recipient to ensure that it is virus free and no responsibility 
is accepted by Toshiba Embedded Software India Pvt. Ltd, for any loss or
damage arising in any way from its use.


Mime
View raw message