jmeter-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Sitnikov <sitnikov.vladi...@gmail.com>
Subject Re: [VOTE] Release JMeter 5.2 RC4
Date Wed, 23 Oct 2019 12:09:19 GMT
OpenJDK8 does not have JavaFX, so the current JMeter code does not compile
with OpenJDK8.
For instance, if you download AdoptOpenJDK build, then you don't have
JavaFX there.

Frankly speaking, I would suggest considering java fx dropped in 5.2, and
re-add it in 5.3 (e.g. as a part of upgrading to Java 11 + OpenJFX11)

The workarounds there could be:
1) Add Java 11 to the build pipeline. For instance, build all the code with
Java 11 with target=1.8
That would enable us to use OpenJFX as a library

2) Use reflection-based code to implement RenderInBrowser (which would be
rather complicated)

3) Require release manager to use Oracle Java 8 for making a release

4) other suggestions?

Vladimir

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message