karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Łukasz Dywicki <l...@code-house.org>
Subject RE: Jansi version in use on trunk
Date Fri, 04 Mar 2011 10:35:54 GMT
It is forked from Hiram jansi repository. ;)

Regarding the code - without Ansi(Ansi) constructor we are not able to
create a template and reuse them. The Style class was introduced to format
multiple strings with same Ansi flags and API close to human thinking. I
didn't know 1.5 release, especially because jansi site says that latest
stable release is 1.4. I really apologize for these problems.

Lukasz


-----Original Message-----
From: Guillaume Nodet [mailto:gnodet@gmail.com] 
Sent: Friday, March 04, 2011 11:26 AM
To: dev@karaf.apache.org
Subject: Re: Jansi version in use on trunk

Btw, I think the reference repository for jansi is the following:
  https://github.com/fusesource/jansi

2011/3/4 Łukasz Dywicki <luke@code-house.org>:
> Hi,
> I just figured that snapshot disappear, so yeah, it stops the build. The
> fast workaround is to build Hiram fork from github [1] it locally.
>
> Hiram, can you take a look for the snapshot? Maybe you could release 1.5
> version? We found 1.5 release in another repository [2].
>
> [1] https://github.com/chirino/jansi
> [2]
>
http://repo.fusesource.com/nexus/content/groups/public/org/fusesource/jansi/
> jansi/1.5/
>
> Best regards,
> Lukasz
>
>
> -----Original Message-----
> From: Jean-Baptiste Onofré [mailto:jb@nanthrax.net]
> Sent: Friday, March 04, 2011 11:15 AM
> To: dev@karaf.apache.org
> Subject: Re: Jansi version in use on trunk
>
> Hi Lujasz,
>
> unfortunately
>
http://repo.fusesource.com/nexus/content/groups/public-snapshots/org/fusesou
> rce/jansi/jansi/1.5-SNAPSHOT/
>
> doesn't contain any jar files.
>
> The problem is there :)
>
> Regards
> JB
>
> On 03/04/2011 11:12 AM, Łukasz Dywicki wrote:
>> Hi,
>> I introduced the version 1.5-SNAPSHOT of jansi to have Ansi(Ansi)
>> constructor. Basically the snapshot is available, but to get it I had to
>> remove metadata cache from
> m2_repo/org/fusesource/jansi/jansi/1.5-SNAPSHOT.
>>
>> This snapshot is timestamped and it it available. I tested this on my
> local
>> environment without snapshot in repo.
>>
>> Best regards,
>> Lukasz
>>
>> -----Original Message-----
>> From: Jean-Baptiste Onofré [mailto:jb@nanthrax.net]
>> Sent: Friday, March 04, 2011 11:05 AM
>> To: dev@karaf.apache.org
>> Subject: Re: Jansi version in use on trunk
>>
>> Lukasz made some changes into Karaf trunk which doesn't seems to be
>> Jansi 1.5 compliant:
>>
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-compiler-plugin:2.0.2:compile
>> (default-compile) on project org.apache.karaf.shell.console: Compilation
>> failure: Compilation failure:
>> [ERROR]
>>
>
/home/onofreje/workspace/karaf/shell/console/src/main/java/org/apache/karaf/
>> shell/console/table/Style.java:[144,15]
>> cannot find symbol
>> [ERROR] symbol  : constructor Ansi(org.fusesource.jansi.Ansi)
>> [ERROR] location: class org.fusesource.jansi.Ansi
>> [ERROR]
>> [ERROR]
>>
>
/home/onofreje/workspace/karaf/shell/console/src/main/java/org/apache/karaf/
>> shell/console/table/Style.java:[157,54]
>> cannot find symbol
>> [ERROR] symbol  : constructor Ansi(org.fusesource.jansi.Ansi)
>> [ERROR] location: class org.fusesource.jansi.Ansi
>> [ERROR] ->  [Help 1]
>> [ERROR]
>>
>>
>> On 03/04/2011 11:03 AM, Guillaume Nodet wrote:
>>> Jansi hasn't changed since a few months:
>>>     https://github.com/fusesource/jansi/commits/master
>>> How can we be incompatible with something that hasn't changed ?
>>>
>>> On Fri, Mar 4, 2011 at 10:56, Jean-Baptiste Onofré<jb@nanthrax.net>
>> wrote:
>>>> Hi all,
>>>>
>>>> On Karaf trunk, we have a reference to Jansi 1.5-SNAPSHOT.
>>>>
>>>> It's a little bit surprising as Jansi 1.5 has been released:
>>>>
>>
>
http://repo.fusesource.com/nexus/content/groups/public/org/fusesource/jansi/
>> jansi/1.5/
>>>>
>>>> but Jansi 1.6-SNAPSHOT is not there:
>>>>
>>
>
http://repo.fusesource.com/nexus/content/groups/public-snapshots/org/fusesou
>> rce/jansi/jansi/
>>>>
>>>> and the Jansi POM still contain version 1.5-SNAPSHOT (and not
>> 1.6-SNAPSHOT):
>>>> git://forge.fusesource.com/jansi.git
>>>>
>>>> Karaf trunk is not compatible with Jansi 1.5 release.
>>>>
>>>> So:
>>>> 1/ the Jansi source should contain 1.6-SNAPSHOT in place of
1.5-SNAPSHOT
>>>> 2/ Could Fuse guys upload a Jansi 1.6-SNAPSHOT version ?
>>>> 3/ we have to update the Karaf trunk POM to use Jansi 1.6-SNAPSHOT
>>>>
>>>> Agree ?
>>>>
>>>> Thanks
>>>> Regards
>>>> JB
>>>>
>>>
>>>
>>>
>>
>
>



-- 
Cheers,
Guillaume Nodet
------------------------
Blog: http://gnodet.blogspot.com/
------------------------
Open Source SOA
http://fusesource.com


Mime
View raw message