karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From karafman <mvangeert...@comcast.net>
Subject Re: archive-kar failing when a bundle's pom cannot be found
Date Wed, 02 Mar 2011 18:26:41 GMT

David Jencks wrote:
> 
> Um, that's behavior you should be happy about IMO :-)  Maven is trying to
> make sure you have a consistent model so you can get consistent results
> from the build.
> 
> How did these pom-less artifacts get into your maven repo?
> 
> thanks
> david jencks
> 
> On Mar 2, 2011, at 9:26 AM, karafman wrote:
> 
>> For the sake of clarity, when I refer to a bundle's pom, I'm referring to
>> the
>> pom of a bundle being resolved from a maven repository, not the pom in
>> which
>> the archive-kar goal is executed.
>> 
>> -----
>> Karafman
>> Slayer of the JEE
>> Pounder of the Perl Programmer
>> 
>> --
>> View this message in context:
>> http://karaf.922171.n3.nabble.com/archive-kar-failing-when-a-bundle-s-pom-cannot-be-found-tp2614934p2614989.html
>> Sent from the Karaf - Dev mailing list archive at Nabble.com.
> 

Honestly, i have no idea how they got in there.  I'm using mvn 3.0.2, and I
deleted my repository after this issue came up the first time.  However, the
issue still exists.  Maybe its a bug in 3.0.2?  I'll try with 2.2.1 and see
if it works.

-----
Karafman
Slayer of the JEE
Pounder of the Perl Programmer

--
View this message in context: http://karaf.922171.n3.nabble.com/archive-kar-failing-when-a-bundle-s-pom-cannot-be-found-tp2614934p2619338.html
Sent from the Karaf - Dev mailing list archive at Nabble.com.

Mime
View raw message