karaf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: trunk build problems
Date Fri, 04 Mar 2011 06:25:19 GMT
Hi David,

regarding maven3, I raised KARAF-482 JIRA and I will work on it this 
week end.

Regards
JB

On 03/04/2011 05:35 AM, David Jencks wrote:
> I'm having trouble building karaf trunk today.
>
> 1. I can't find org.fusesource.jansi:jansi:1.5-SNAPSHOT anywhere.  However 1.5 looks
like it was released last november.  Furthermore Style says it wraps Ansi with a fluent api
but the Ansi from 1.5 looks already fluent.  Can't we use the released jansi and use its fluent
api?  AFAICT this dependency was upgraded yesterday 1.4 to 1.5-SNAPSHOT in rev 1076175 by
ldywicki at which point the Style class was added.
>
> 2. I'm getting an itest failure from archetypes itests (last project) and noticed this...
>
> [ maven embedder INFO] Archetype repository missing. Using the one from [org.apache.karaf.archetypes:archetypes-command:2.1.4]
found in catalog remote
>
> is this an external dependency that the archtype be deployed to a catalog?  Or maybe
something new with maven 3???
>
> thanks
> david jencks
>

Mime
View raw message