karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3085) features:chooseurl/feature:repo-add should support "real" version range
Date Tue, 22 Jul 2014 08:51:39 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3085?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14070018#comment-14070018
] 

Jean-Baptiste Onofré commented on KARAF-3085:
---------------------------------------------

Fixed on karaf-3.0.x (even if version range is not yet supported in pax-url-aether): https://git-wip-us.apache.org/repos/asf?p=karaf.git;a=commitdiff;h=52fe48b25f1b7f9e3a443edec9feb1793e172f7e

> features:chooseurl/feature:repo-add should support "real" version range
> -----------------------------------------------------------------------
>
>                 Key: KARAF-3085
>                 URL: https://issues.apache.org/jira/browse/KARAF-3085
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0, 2.3.6, 3.0.3, 2.4.1
>
>
> Karaf uses the etc/org.apache.karaf.features.repos.cfg configuration file to define the
location of the project features.
> Unfortunately, the features URLs in this file doesn't real support the version range.
It would be great to use a version resolver supporting [2,3) for instance.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message