karaf-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] [Commented] (KARAF-3362) Version for Jetty in standard features is wrong.
Date Tue, 18 Nov 2014 07:09:34 GMT

    [ https://issues.apache.org/jira/browse/KARAF-3362?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14215809#comment-14215809
] 

Jean-Baptiste Onofré commented on KARAF-3362:
---------------------------------------------

For Jetty 8, it's not so simple, as Jetty API changed between 8 and 9. So, it means that we
should use different Pax Web version, and Pax Web version depends to different OSGi spec version.
Let me check what we can do here.

> Version for Jetty in standard features is wrong.
> ------------------------------------------------
>
>                 Key: KARAF-3362
>                 URL: https://issues.apache.org/jira/browse/KARAF-3362
>             Project: Karaf
>          Issue Type: Bug
>          Components: karaf-feature
>    Affects Versions: 4.0.0.M1
>            Reporter: Daniel Kulp
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 4.0.0
>
>
> In the standard-4.0.0.M1 features file for Karaf 4, the Jetty version for the jetty feature
is listed as 8.1.9.v20130131.   However, it just depends on pax-jetty which pulls in 9.0.7.v20131107.
> There are two problems:
> 1) Some applications (CXF/Camel) need Jetty 8.x so having a feature that would properly
install 8.x would be useful.  
> 2) If it's installing 9.x, it should have that version properly specified.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message