libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Reategui (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-439) Cloudstack list_nodes does not fill in image field
Date Mon, 16 Dec 2013 21:42:08 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-439?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13849755#comment-13849755
] 

Carlos Reategui commented on LIBCLOUD-439:
------------------------------------------

I'm fine with that since I am only using this for CS.  Not sure how others would feel about
consistency since there is an image field already.  Or are you saying that other cloud adapters
are also returning these extra fields and not the image one?

> Cloudstack list_nodes does not fill in image field
> --------------------------------------------------
>
>                 Key: LIBCLOUD-439
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-439
>             Project: Libcloud
>          Issue Type: Bug
>          Components: Compute
>    Affects Versions: 0.13.2
>         Environment: python 2.6
>            Reporter: Carlos Reategui
>            Priority: Trivial
>
> I made the following change but not sure if it is consistent with what other drivers
put in the image field:
> --- apache-libcloud-0.13.2/libcloud/compute/drivers/cloudstack.py       2013-09-15 15:40:43.000000000
+0000
> +++ cloudstack.py       2013-11-14 04:05:26.000000000 +0000
> @@ -229,6 +229,7 @@
>                  public_ips=public_ips,
>                  private_ips=private_ips,
>                  driver=self,
> +                image=vm.get('templatename', None),
>                  extra={'zoneid': vm['zoneid'], }
>              )
> Another alternative could be templateid instead of templatename



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message