libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-768) UnicodeDecodeError occurs when LIBCLOUD_DEBUG is set
Date Sat, 07 Nov 2015 15:03:10 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-768?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14995242#comment-14995242
] 

ASF GitHub Bot commented on LIBCLOUD-768:
-----------------------------------------

GitHub user atsaki opened a pull request:

    https://github.com/apache/libcloud/pull/628

    [LIBCLOUD-768] UnicodeDecodeError occurs when LIBCLOUD_DEBUG is set

    This fixes UnicodeDecodeError when LIBCLOUD_DEBUG is set and non-ascii character is included
in response.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/atsaki/libcloud 768_fix_unicodedecode_error

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/libcloud/pull/628.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #628
    
----
commit 295e69e67125cec685822e25557b1b708642e129
Author: Atsushi Sasaki <atsaki01@gmail.com>
Date:   2015-11-07T14:56:28Z

    decode response with utf-8

----


> UnicodeDecodeError occurs when LIBCLOUD_DEBUG is set
> ----------------------------------------------------
>
>                 Key: LIBCLOUD-768
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-768
>             Project: Libcloud
>          Issue Type: Bug
>            Reporter: Atsushi Sasaki
>
> UnicodeDecodeError occurs when LIBCLOUD_DEBUG is set and api response includes non-ascii
character



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message