libcloud-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miguel Caballer (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LIBCLOUD-874) Does Libcloud have plans to support new versions of OpenStack?
Date Fri, 21 Sep 2018 08:58:00 GMT

    [ https://issues.apache.org/jira/browse/LIBCLOUD-874?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16623286#comment-16623286
] 

Miguel Caballer commented on LIBCLOUD-874:
------------------------------------------

Current driver version uses these deprecated nova API calls:
 * /os-volumes
 * /os-snapshots
 * /os-security-groups
 * /os-security-group-rules
 * /os-floating-ips

As stated in the nova documentation all of them are deprecated.

[https://docs.openstack.org/releasenotes/nova/newton.html]

It means that for Newton and newer versions the driver will not work.

> Does Libcloud have plans to support new versions of OpenStack?
> --------------------------------------------------------------
>
>                 Key: LIBCLOUD-874
>                 URL: https://issues.apache.org/jira/browse/LIBCLOUD-874
>             Project: Libcloud
>          Issue Type: Improvement
>            Reporter: Jim
>            Priority: Blocker
>
> In the latest version 1.3.0, Libcloud still use Nova API to provide the image, network
and volume functions, which are deprecated in current OpenStack verison. Does Libcloud have
plans to support Glance v2, Neutron v2.0 and Cinder v2 API for OpenStack?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message